ospf多区域配置

发布于 2020-01-07  84 次阅读


ospf多区域.png

配置:
R1


dis cu                              //
#
sysname R1                            //
#
undo info-center enable                            //
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher 7/YM)|{Cp)ajUn1vMEIB)N7#
 local-user admin service-type http
#
firewall zone Local
 priority 16
#
interface Ethernet0/0/0
#
interface Ethernet0/0/1
#
interface Serial0/0/0
 link-protocol ppp
#
interface Serial0/0/1
 link-protocol ppp
#
interface Serial0/0/2
 link-protocol ppp
#
interface Serial0/0/3
 link-protocol ppp
#
interface GigabitEthernet0/0/0                            //
 ip address 21.0.0.1 255.0.0.0                            //
#
interface GigabitEthernet0/0/1                            //
 ip address 23.0.0.1 255.0.0.0                            //
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
wlan
#
interface NULL0
#
interface LoopBack0                            //
 ip address 10.1.1.1 255.255.0.0                            //
#
interface LoopBack1                            //
 ip address 10.2.1.1 255.255.0.0                            //
#
ospf 1                                //
 area 0.0.0.0                            //
  network 21.0.0.0 0.255.255.255                            //
  network 23.0.0.0 0.255.255.255                            //
 area 0.0.0.2                            //
  network 10.1.0.0 0.0.255.255                            //
  network 10.2.0.0 0.0.255.255                            //
#
user-interface con 0
user-interface vty 0 4
user-interface vty 16 20
#
return

R2


dis cu                            //
#
sysname R2                            //
#
undo info-center enable                            //
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher [Fr/TPSz)9ZypQCee$t3RN8#
 local-user admin service-type http
#
firewall zone Local
 priority 16
#
interface Ethernet0/0/0
#
interface Ethernet0/0/1
#
interface Serial0/0/0
 link-protocol ppp
#
interface Serial0/0/1
 link-protocol ppp
#
interface Serial0/0/2
 link-protocol ppp
#
interface Serial0/0/3
 link-protocol ppp
#
interface GigabitEthernet0/0/0                            //
 ip address 21.0.0.2 255.0.0.0                            //
#
interface GigabitEthernet0/0/1                            //
 ip address 22.0.0.1 255.0.0.0                            //
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
wlan
#
interface NULL0
#
interface LoopBack0                            //
 ip address 172.17.0.1 255.255.0.0                            //
#
interface LoopBack1                            //
 ip address 172.30.0.1 255.255.0.0                            //
#
ospf 1                            //
 area 0.0.0.0                            //
  network 21.0.0.0 0.255.255.255                            //
  network 22.0.0.0 0.255.255.255                            //
 area 0.0.0.1                            //
  network 172.17.0.0 0.0.255.255                            //
  network 172.30.0.0 0.0.255.255                            //
#
user-interface con 0
user-interface vty 0 4
user-interface vty 16 20
#
return

R3


dis cu                            //
#
sysname R3                            //
#
undo info-center enable                            //
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher gH4*"IogBIajUn1vMEIBDN7#
 local-user admin service-type http
#
firewall zone Local
 priority 16
#
interface Ethernet0/0/0
#
interface Ethernet0/0/1
#
interface Serial0/0/0
 link-protocol ppp
#
interface Serial0/0/1
 link-protocol ppp
#
interface Serial0/0/2
 link-protocol ppp
#
interface Serial0/0/3
 link-protocol ppp
#
interface GigabitEthernet0/0/0                            //
 ip address 23.0.0.2 255.0.0.0                            //
#
interface GigabitEthernet0/0/1                            //
 ip address 22.0.0.2 255.0.0.0                            //
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
wlan
#
interface NULL0
#
interface LoopBack0                            //
 ip address 192.168.10.1 255.255.255.0                            //
#
interface LoopBack1                            //
 ip address 192.168.11.1 255.255.255.0                            //
#
ospf 1                            //
 area 0.0.0.0                            //
  network 23.0.0.0 0.255.255.255                            //
  network 22.0.0.0 0.255.255.255                            //
 area 0.0.0.3                            //
  network 192.168.10.0 0.0.0.255                            //
  network 192.168.11.0 0.0.0.255                            //
#
user-interface con 0
user-interface vty 0 4
user-interface vty 16 20
#
return

一定要优秀,堵住悠悠众口。